<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rHJ9vP1Xz0ktKr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"wave"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "wave/web/politics",
    "authors": [
                  
                    {
                      "_id": "Stephen Goin",
                      "name": "Stephen Goin",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2020/05/25/voters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches/",
    "contentId": "LVBZZSIPHZBX7IXC7KMGXNG7R4",
    "contentName": "Voters concerned with absentee ballot discrepancies as June primary approaches",
    "contentOwner": "wave",
    "contentTags":  [
                  
                    {
                      "text": "voting",
                      "description": "voting",
                      "slug": "voting"
                    },
                  
                ],
    "contentType": "story",
    "datePublished": "2020-05-25T17:52:42.055Z",
    "description": "People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process.",
    "distributorCategory": "staff",
    "distributorMode": "reference_denormalized",
    "distributorName": "Gray TV Stations",
    "distributorReferenceId": "dee592ee-659e-4038-a289-0bfe818887ca",
    "distributorSubCategory": "gray-original-content",
    "hasVideo": "true",
    "metaDescription": "People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "Politics",
                            "_id": "/politics",
                            "path": "/politics",
                          }
                        
                      ,
    "publishedDay": "25",
    "publishedMonth": "05",
    "publishedYear": "2020",
    "stationName": "wave",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="SFYNksekR2BFful_aFAAiv_o7N3lHUgUmmUbhJ0iOoE"/> <title>Voters concerned with absentee ballot discrepancies as June primary approaches</title> <meta name="keywords" content="primary election, mail, absentee ballots"> <meta name="news_keywords" content="primary election, mail, absentee ballots"/> <meta name="date" content="2020-05-25T17:52:42.956Z"/> <meta itemprop="description" name="description" content="People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.wave3.com/2020/05/25/voters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches/"> <meta name="twitter:title" content="Voters concerned with absentee ballot discrepancies as June primary approaches"/> <meta name="twitter:image" content="https://www.wave3.com/resizer/RJSQSHttJCMNWNzQU154IoPUMtQ=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/IZAGN3W7BNC67GB6HRMPDMZCLM.jpg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process."/> <meta name="twitter:site" content="@wave3news"/> <meta name="twitter:creator" content="@wave3news"> <meta property="og:url" content="https://www.wave3.com/2020/05/25/voters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches/"/> <meta property="og:title" content="Voters concerned with absentee ballot discrepancies as June primary approaches"/> <meta itemprop="image" property="og:image" content="https://www.wave3.com/resizer/RJSQSHttJCMNWNzQU154IoPUMtQ=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/IZAGN3W7BNC67GB6HRMPDMZCLM.jpg"/> <meta property="og:description" content="People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.wave3.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="172784009442800"/> <meta property="fb:pages" content="140776323685"/> <meta property="fb:admins" content="644426401"/> <meta name="burst" content="WAVE"/> <meta property="article:publisher" content="https://www.facebook.com/wave3news"> <meta property="article:tag" content="voting"> <link rel="amphtml" href="/2020/05/25/voters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches/?outputType=amp"> <meta name="author" content="Stephen Goin"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Voters concerned with absentee ballot discrepancies as June primary approaches",
        
        "image": {
          "@type": "ImageObject",
          "url": "https://www.wave3.com/resizer/RJSQSHttJCMNWNzQU154IoPUMtQ=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/IZAGN3W7BNC67GB6HRMPDMZCLM.jpg",
          "height": 1080.0,
          "width": 1200
        },
        
        "datePublished": "2020-05-25T19:25:38.090Z",
        "dateModified": "2020-05-25T17:52:42.956Z",
        "articleBody": "LOUISVILLE, Ky. (WAVE) – People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process.Bullitt County resident Ron Crouch said he has come across several concerns.“When I looked at the instructions, they were dated October 2017 - two and a half years ago,” Crouch said.WAVE 3 News obtained a copy of these absentee voting instructions. The one page, three step guide appears to contain information that was not updated for the June 23 primary. In the section titled ‘Step 3: Return Envelopes to County Clerk’ voters are instructed to “affix proper postage to outer envelope” and told there will be a postage or delivery fee. In the same section, voters are also told “hand delivery will not be accepted&#034; for mail-in absentee ballots.Speaking in Frankfort Friday, Sec. of State Michael Adams explained the state will pay for the postage needed to mail absentee ballots back to county clerks. Adams also stated hand delivery of absentee ballots is allowed.“If you want the personal security of hand delivering your ballot instead of putting it in the mail, you can do that. In fact, we&#039;re providing drop boxes free of charge to all the counties if they would like one so that you can personally go to your county clerk and drop your ballot in the bin,” Adams said. “These drop boxes will be under supervision by the clerks staff, they’ll be completely safe.”Crouch said he has also seen inconsistencies with the prepaid postage that appears on absentee ballot return envelopes. His own ballot return postage was $1.10 in Bullitt County. Another concerned voter told WAVE 3 News her ballot return postage was $0.55 in Jefferson County.“If the postage was insufficient will the United States post office reject those,” Crouch asked.Crouch said he even has concerns with the application process needed to get an absentee ballot.Registered voters can request an absentee ballot application by phone, fax, email, mail or in person at a County Clerk’s office. Unless the application is received in person, it will be mailed to the person who requested it. Absentee voters can then submit the application in person or return in by mail. Crouch believes the additional cost of postage and the timeline it would take to receive and submit the application by mail could all act as potential barriers for voters.As of Friday, registered voters in Kentucky can also apply for an absentee ballot online at govoteky.com“Well there&#039;s a portal now that people can go to, it&#039;s very simple. It just seems to be the best and safest way to vote this year,” District 7 Metro councilwoman Paula McCraney said.McCraney, who worked for eight years at the Jefferson County Clerks Office, said her constituents have not reported any issues so far with absentee ballots.Registered voters in Jefferson County are still able to vote in-person at the Kentucky Exposition Center on June 23. No other polling places will be open in the county.The last day to register to vote is May 26 while the last day to request an absentee ballot is June 15.Copyright 2020 WAVE 3 News. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Stephen Goin"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "WAVE",
        "logo": {
          "@type": "ImageObject",
          "url": "https://www.wave3.com/pb/resources/images/rm_icons/wave-icon.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "WAVE",
        "url": "https://www.wave3.com",
        "logo": "https://www.wave3.com/pb/resources/images/rm_icons/wave-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/wave3news" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-framework96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/wave-logo.svg?v=90)}.logo.logo-footer{background-image:url(/pb/resources/images/footer_icons/wave-logo.svg?v=90)}</style> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-framework96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-features96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-services96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <script src="/pb/gr/c/default/rHJ9vP1Xz0ktKr/arcAdsJS/cdbd7d78da.js?v=90"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> <script src="//cdn.connatix.com/min/connatix.renderer.infeed.min.js" data-connatix-token="f7711a60-cc3f-44d8-94f8-3265d3a5e864" async></script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="faYVSr1Xz0ktKr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.graytvlocal.com/market/louisville-ky" class="color-grey-dark">Support Local Businesses</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wave3.com/traffic" class="color-grey-dark">Traffic</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wave3.com/health" class="color-grey-dark">Focus on Health</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wave3.com/business/listens-live/" class="color-grey-dark">Listens Live!</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wave3.com/business/legal/legal-brief" class="color-grey-dark">Legal Brief</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wave3.com/news/consumer/your-money/" class="color-grey-dark">Your Money</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://a.pgtb.me/1H0Zts" class="color-grey-dark">Pass The Cash</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f0aKfloXz0ktKr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0ExsO8Xz0ktKr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.wave3.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="https://www.wave3.com/health/coronavirus/" class="">CORONAVIRUS</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="https://www.wave3.com/video-gallery/" class="">VIDEO</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.wave3.com/about-us/" class="">About Us</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/community" class="">Community</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="https://www.derbycityweekend.com/" class="">DERBY CITY WEEKEND</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div class="app-bar-tray" data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <div class="flex-grid"> <div class="tray-section tray-section-1 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/homepage" class="color-white">Home</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.wave3.com/video-gallery/" class="color-white">VIDEO</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.wave3.com/live/" class="color-white">Watch Live</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="http://www.wave3.com/apps" class="color-white">Wave 3 Apps</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.derbycityweekend.com/" class="color-white">Derby City Weekend</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/news/investigate" class="color-white">Troubleshooter</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/business/listens-live" class="color-white">Listens Live</a> </div> </div> </div> </div> <div class="tray-section tray-section-2 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news" class="color-white">News</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.wave3.com/news/breonna-taylor-case" class="color-white">Breonna Taylor</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.wave3.com/health/coronavirus/" class="color-white">Coronavirus</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/news/crime" class="color-white">Crime</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/news/national" class="color-white">National</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://www.wave3.com/news/consumer/make-ends-meet/" class="color-white">Make Ends Meet</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/news/political" class="color-white">Political</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/news/goodnews" class="color-white">Positively WAVE</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="/news/tbys" class="color-white">Taking Back Your Streets</a> </div> </div> </div> </div> <div class="tray-section tray-section-3 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news/local" class="color-white">Local</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/news/local/louisville-metro" class="color-white">Louisville Metro</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/news/local/bullitt-county" class="color-white">Bullitt County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/news/local/hardin-county" class="color-white">Hardin County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/news/local/nelson-county" class="color-white">Nelson County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/news/local/oldham-county" class="color-white">Oldham County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/news/local/shelby-county" class="color-white">Shelby County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/news/local/spencer-county" class="color-white">Spencer County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="/news/local/clark-county" class="color-white">Clark County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="/news/local/floyd-county" class="color-white">Floyd County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-12"> <a href="/news/local/harrison-county" class="color-white">Harrison County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-13"> <a href="/news/local/scott-county" class="color-white">Scott County</a> </div> </div> </div> </div> <div class="tray-section tray-section-4 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/weather" class="color-white">Weather</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.wave3.com/weather/#radar" class="color-white">Radar</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/weather/cams" class="color-white">Skycams</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/weather/blog" class="color-white">Weather Blog</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/weather/closings" class="color-white">Closings</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/weather/weather-facts" class="color-white">Hokey Weather Facts</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/weather/education" class="color-white">Education</a> </div> </div> </div> </div> <div class="tray-section tray-section-5 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/traffic" class="color-white">Traffic</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/traffic/gas-prices" class="color-white">Gas Prices</a> </div> </div> </div> </div> <div class="tray-section tray-section-6 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/about-us" class="color-white">About Us</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.wave3.com/about-us/" class="color-white">About Us</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.wave3.com/2018/08/26/wave-jobs/" class="color-white">Wave 3 Jobs</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.wave3.com/2018/08/26/contact-wave-email-addresses-social-media/" class="color-white">Contact Us</a> </div> </div> </div> </div> <div class="tray-section tray-section-7 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/community" class="color-white">Community</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.wave3.com/angel-tree/" class="color-white">Angel Tree</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/community/wave-country" class="color-white">WAVE Country</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/community/pass-the-cash" class="color-white">Pass the Cash</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/community/imagination-library" class="color-white">Imagination Library</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/community/calendar" class="color-white">Calendar</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.wave3.com/video-gallery/community/sounds-of-the-season/" class="color-white">Sounds Of The Season</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/news/editorial" class="color-white">Editorial</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="/news/education" class="color-white">Education</a> </div> </div> </div> </div> <div class="tray-section tray-section-8 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/sports" class="color-white">Sports</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/sports/ncaa" class="color-white">NCAA</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.wave3.com/video-gallery/sports/" class="color-white">Sports Video</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.wave3.com/video-gallery/sports/gameon/" class="color-white">GameOn</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.derbycityweekend.com/channel/digital-derby-guide-home/" class="color-white">Digital Derby Guide</a> </div> </div> </div> </div> <div class="tray-section tray-section-9 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming" class="color-white">Programming</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/programming/schedule" class="color-white">Programming Schedule</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.fullcourtgreta.com/" class="color-white">Full Court Press with Greta Van Susteren</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="http://www.circleallaccess.com" class="color-white">Circle - Country Music & Lifestyle</a> </div> </div> </div> </div> <div class="tray-section tray-section-10 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/health" class="color-white">Health</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.wave3.com/health/" class="color-white">Focus on Health - American Senior Communities</a> </div> </div> </div> </div> <div class="tray-section tray-section-11 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/contests" class="color-white">Contests</a> </h3> </div> </div> </div> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0MEpCZXz0ktKr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-wave-breaking/" data-url="/pb/api/v2/render/feature" data-website="wave" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fZgFpz1Xz0ktKr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/wave-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="wave"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fOcnHR1Xz0ktKr"> <div id="ad1322-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1322" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1322",slotName:"wave/web/politics",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"LVBZZSIPHZBX7IXC7KMGXNG7R4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="f0G8x4vXz0ktKr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> <li class=""> <a class="tag unstyled-link call-to-action uppercase bold unstyled-link tag-first" href="https://www.wave3.com/politics"> Politics </a> </li> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Voters concerned with absentee ballot discrepancies as June primary approaches</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-article-goldfish-video" id=""> <div class="video"> <div class="goldfish-video" data-video-id="powa-514-932ca36d-579c-4d25-a8f5-099df60b22ac" data-script-path="d3mo2m0b34ee8e" data-environment="prod"></div> <div class="goldfish-player" data-page-on="1" data-producer=""> <div class="powa" id="powa-514-932ca36d-579c-4d25-a8f5-099df60b22ac" data-ping-rate="15" data-org="raycom" data-uuid="932ca36d-579c-4d25-a8f5-099df60b22ac" data-playthrough="true" data-sticky="true" data-autoplay="true" data-preroll-ad-path="63316753/wave/web/news" data-ads="true"></div> </div> <figcaption class="caption-text spaced spaced-top spaced-xs flex-container-row justify-space-between"> <div>Absentee ballots causing concern in Kentucky</div> </figcaption> </div> </div> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0qBKcXXz0ktKr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share sharebar flex-container-column text-align-right"> <button class="social-icon spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Voters+concerned+with+absentee+ballot+discrepancies+as+June+primary+approaches&amp;url=https%3A%2F%2Fwww.wave3.com%2F2020%2F05%2F25%2Fvoters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-twitter social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <button class="social-icon spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.wave3.com%2F2020%2F05%2F25%2Fvoters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches%2F&amp;title=Voters+concerned+with+absentee+ballot+discrepancies+as+June+primary+approaches', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-facebook-f social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <a href="mailto:?subject=Voters%20concerned%20with%20absentee%20ballot%20discrepancies%20as%20June%20primary%20approaches&amp;body=Read%20more%20on%20Voters%20concerned%20with%20absentee%20ballot%20discrepancies%20as%20June%20primary%20approaches%20at%20https%3A%2F%2Fwww.wave3.com%2F2020%2F05%2F25%2Fvoters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches%2F"> <button class="social-icon spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="far fa-envelope social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0z3yJ5Xz0ktKr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/Stephen Goin/"> <span class="font-bold ">Stephen Goin</span></a> <span class="font-bold">|</span> <span class="timestamp"> May 25, 2020 at 1:52 PM EDT - Updated May 25 at 3:25 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0OiAz6Xz0ktKr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>LOUISVILLE, Ky. (WAVE) – People in Kentucky are being encouraged to vote with absentee ballots for the June 23 primary election. However, some voters say they are worried about apparent issues in the process.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Bullitt County resident Ron Crouch said he has come across several concerns.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“When I looked at the instructions, they were dated October 2017 - two and a half years ago,” Crouch said.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>WAVE 3 News obtained a copy of these absentee voting instructions. The one page, three step guide appears to contain information that was not updated for the June 23 primary. In the section titled ‘Step 3: Return Envelopes to County Clerk’ voters are instructed to “affix proper postage to outer envelope” and told there will be a postage or delivery fee. In the same section, voters are also told “hand delivery will not be accepted" for mail-in absentee ballots.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad258-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad258" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad258",slotName:"wave/web/politics/LVBZZSIPHZBX7IXC7KMGXNG7R4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Speaking in Frankfort Friday, Sec. of State Michael Adams explained the state will pay for the postage needed to mail absentee ballots back to county clerks. Adams also stated hand delivery of absentee ballots is allowed.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“If you want the personal security of hand delivering your ballot instead of putting it in the mail, you can do that. In fact, we're providing drop boxes free of charge to all the counties if they would like one so that you can personally go to your county clerk and drop your ballot in the bin,” Adams said. “These drop boxes will be under supervision by the clerks staff, they’ll be completely safe.”</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Crouch said he has also seen inconsistencies with the prepaid postage that appears on absentee ballot return envelopes. His own ballot return postage was $1.10 in Bullitt County. Another concerned voter told WAVE 3 News her ballot return postage was $0.55 in Jefferson County.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad1415-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1415" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1415",slotName:"wave/web/politics/LVBZZSIPHZBX7IXC7KMGXNG7R4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“If the postage was insufficient will the United States post office reject those,” Crouch asked.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1616-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1616" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1616",slotName:"wave/web/politics/LVBZZSIPHZBX7IXC7KMGXNG7R4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Crouch said he even has concerns with the application process needed to get an absentee ballot.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Registered voters can request an absentee ballot application by phone, fax, email, mail or in person at a County Clerk’s office. Unless the application is received in person, it will be mailed to the person who requested it. Absentee voters can then submit the application in person or return in by mail. Crouch believes the additional cost of postage and the timeline it would take to receive and submit the application by mail could all act as potential barriers for voters.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>As of Friday, registered voters in Kentucky can also apply for an absentee ballot online at <a href="http://govoteky.com/" target="_blank">govoteky.com</a></p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Well there's a portal now that people can go to, it's very simple. It just seems to be the best and safest way to vote this year,” District 7 Metro councilwoman Paula McCraney said.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1910-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1910" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1910",slotName:"wave/web/politics/LVBZZSIPHZBX7IXC7KMGXNG7R4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>McCraney, who worked for eight years at the Jefferson County Clerks Office, said her constituents have not reported any issues so far with absentee ballots.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Registered voters in Jefferson County are still able to vote in-person at the Kentucky Exposition Center on June 23. No other polling places will be open in the county.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad304-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad304" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad304",slotName:"wave/web/politics/LVBZZSIPHZBX7IXC7KMGXNG7R4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The last day to register to vote is May 26 while the last day to request an absentee ballot is June 15.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2020 WAVE 3 News. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-connatix" id="fwaAKx1Xz0ktKr"> <div class="flex-grid ad-connatix spaced spaced-lg spaced-top spaced-bottom "> <div class="col desktop-12 tablet-12 mobile-12"> <div id="connatix-highlights-embed" class="connatix-container box-shadow-light"></div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f06efnJXz0ktKr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.wave3.com/2020/05/25/voters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.wave3.com/2020/05/25/voters-concerned-with-absentee-ballot-discrepancies-june-primary-approaches/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="fzMDJM1Xz0ktKr"> <div id="ad279-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad279" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad279",slotName:"wave/web/politics",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"LVBZZSIPHZBX7IXC7KMGXNG7R4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="f47aum1Xz0ktKr"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-partly-cloudy" data-default-location-code="USKY1096" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="wave" data-location-code="USKY1096" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USKY1096,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.wave3.com/weather"> <img class="radar-image" src="https://webpubcontent.raycommedia.com/wave/esplive/radar-180.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="88" data-temp-c="31"> 88</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/66_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Louisville, KY</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.wave3.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> <div class="flex-container-row justify-center spaced spaced-md spaced-bottom spaced-top font-semi-bold"> <span class="spaced spaced-right spaced-sm">Sponsored By</span> <div id="ad1707-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1707" class="arcad ad-120x30"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1707",slotName:"wave/web/weather-widget",adType:"weather-sponsorship",dimensions:"[[[120, 30]], [[120, 30]], [[120, 30]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"weather",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:false,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="frRRQ42Xz0ktKr"> <div class="article-author-bio"> <div class="article-author-bio flex-grid flex-feature"> <h3 class="bold uppercase"> <span class="rectangle"></span> Author </h3> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Stephen Goin" data-src="https://www.wave3.com/resizer/-3QxhgzOJh0ivDWYo4ML7-TQ4cg=/1400x0/s3.amazonaws.com/arc-authors/raycom/382e1bbe-8950-421d-b617-e86c0f20d0b3.jpg" src="https://www.wave3.com/resizer/ogXM2RciyKbZciq6oeHQKkvdqiU=/0x10/s3.amazonaws.com/arc-authors/raycom/382e1bbe-8950-421d-b617-e86c0f20d0b3.jpg"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/Stephen Goin/"> <h3 class="promo-header">Stephen Goin</h3> </a> <h4 class="hidden font-normal color-grey-dark"></h4> <h4 class="spaced spaced-xs font-normal color-grey-dark">Louisville, Ky.</h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://twitter.com/stephengoin" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://www.facebook.com/StephenGoinTV/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:stephen.goin@wave3.com?subject=Voters%20concerned%20with%20absentee%20ballot%20discrepancies%20as%20June%20primary%20approaches&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">Stephen Goin is a multi-media journalist at WAVE 3 News.</p> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-mailchimp-signup" id="fxwHfN1Xz0ktKr"> </div> <div class=" pb-layout-item pb-chain pb-c-single-chain full" id="c0NRdx1Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fhr3sb2Xz0ktKr"> <div class="flex-feature "> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-92200" data-content-service="content-feed"> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f09JMK9Xz0ktKr"> <div id="ad933-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad933" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad933",slotName:"wave/web/politics",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"LVBZZSIPHZBX7IXC7KMGXNG7R4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c008fu9Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fmrOMh1Xz0ktKr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-162351" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/05/14/mcconnell-hits-democrats-totally-unserious-relief-bill/"> <img class="width-full " alt="McConnell hits Democrats’ ‘totally unserious’ relief bill" src="https://www.wave3.com/resizer/15KuHwZOeka9gAeugN6FGUni0As=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/B3EC4TNWKNBGNALOFQOHVPLSKA.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/14/mcconnell-hits-democrats-totally-unserious-relief-bill/"> McConnell hits Democrats’ ‘totally unserious’ relief bill</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published May 14, 2020 at 6:06 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/05/14/jefferson-county-use-kentucky-state-fairgrounds-primary-election/"> <img class="width-full " alt="Jefferson County to use Kentucky state fairgrounds for primary election" src="https://www.wave3.com/resizer/JKWzA2__PAjAKtnJ0BDJt2BdLbM=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/ALRR6MSC3NGFRKXBJ5SQRPQNEA.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/14/jefferson-county-use-kentucky-state-fairgrounds-primary-election/"> Jefferson County to use Kentucky state fairgrounds for primary election</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Charles Gazaway</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published May 14, 2020 at 3:05 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/05/08/federal-judge-rules-all-kentucky-churches-can-have-in-person-services-starting-this-sunday/"> <img class="width-full " alt="Federal judge rules all Kentucky churches can have in-person services starting this Sunday " src="https://www.wave3.com/resizer/6i3Rbuw_rkO7nYQVqbj1orOd1Ec=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/4K6D2LVPHRFAND2OWCCY6SMX5M.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/08/federal-judge-rules-all-kentucky-churches-can-have-in-person-services-starting-this-sunday/"> Federal judge rules all Kentucky churches can have in-person services starting this Sunday </a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published May 8, 2020 at 11:17 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/05/06/kentucky-church-files-lawsuit-against-beshear-over-in-person-services/"> <img class="width-full " alt="Kentucky church files lawsuit against Beshear over in-person services" src="https://www.wave3.com/resizer/cm2bgnpmv24DGpkr4J_uaT_3r5g=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/XGK65U33XRC7XAMZ6FJKIJTQHA.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/06/kentucky-church-files-lawsuit-against-beshear-over-in-person-services/"> Kentucky church files lawsuit against Beshear over in-person services</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WKYT TV</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published May 6, 2020 at 12:43 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0XShVkXz0ktKr"> <div id="ad80-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad80" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad80",slotName:"wave/web/politics",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"LVBZZSIPHZBX7IXC7KMGXNG7R4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fU2oFF1Xz0ktKr"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.wave3.com"> <div class="logo logo-large logo-footer"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 725 S. Floyd Street<br/>Louisville, KY 40203<br/>(502) 585-2201 </p> <a class="call-to-action uppercase color-white" href="http://www.wave3.com/2018/08/26/contact-wave-email-addresses-social-media/">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wave" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@wave3.com" class="color-white">publicfile@wave3.com<br/>(502) 585-2201</a></li> <li><a href="https://www.wave3.com/2020/04/08/wave-eeo-public-file-report/" class="color-white">EEO Report</a></li> <li><a href="http://www.wave3.com/story/12062304/closed-captioning-contact-information/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WAVE Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/wave3news" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/wave3news" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wave" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@wave3.com" class="color-white">publicfile@wave3.com<br/>(502) 585-2201</a></li> <li><a href="https://www.wave3.com/2020/04/08/wave-eeo-public-file-report/" class="color-white">EEO Report</a></li> <li><a href="http://www.wave3.com/story/12062304/closed-captioning-contact-information/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WAVE Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/wave3news" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/wave3news" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rHJ9vP1Xz0ktKr/render.js?v=90'></script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events.perso.aws.arc.pub/api/save-perf",TESTS_API:"https://bandito.perso.aws.arc.pub/api/variants",EVENTS_API:"https://bandito-events.perso.aws.arc.pub/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script async src="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-index96cfbfc61ff908bdad44.js"></script>